Harley Davidson Pan America Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
Is anyone having issues with their Bluetooth headsets? I've tried two different ones (one HD) and they either randomly drop 20 minutes into the ride, or just won't connect once the bike is running. On ACC they connect fine 🤷‍♂️
 

·
Registered
2021 Deadwood (OD) Green PanAm, 2007 Pearl Yellow RK Custom
Joined
·
175 Posts
Is anyone having issues with their Bluetooth headsets? I've tried two different ones (one HD) and they either randomly drop 20 minutes into the ride, or just won't connect once the bike is running. On ACC they connect fine 🤷‍♂️
Here's my experience/how it's worked for me.
I currently have (in market for new one) a Bilt helmet with sena BT headset already on it/installed when I bought it.

So I turn on BT on my cell, then helmet and then the bike. Then they all connected and able to utilize the controls on the bike.
Oh I did (first time) pair them thru bike and now when turn all three on they connect.
I have not had any issues (dropping/disconnecting) only thing is the helmet headset volume is louder when paired to just my phone but I pair with bike so I have controls.
I use sirius xm for my listening pleasures.

So to answer question, no i have not and not sure what I can suggest to help but hope you get it figured out.
 

·
Registered
Joined
·
14 Posts
Generally I've had little to no issues pairing my iPhone 12, H-D branded Sena 30k and 22 PAS. One time my bike wouldn't find my headset even though they are pre paired so I turned the bike on and off and it worked flawlessly again.
 

·
Registered
Joined
·
13 Posts
Here's my experience/how it's worked for me.
I currently have (in market for new one) a Bilt helmet with sena BT headset already on it/installed when I bought it.

So I turn on BT on my cell, then helmet and then the bike. Then they all connected and able to utilize the controls on the bike.
Oh I did (first time) pair them thru bike and now when turn all three on they connect.
I have not had any issues (dropping/disconnecting) only thing is the helmet headset volume is louder when paired to just my phone but I pair with bike so I have controls.
I use sirius xm for my listening pleasures.

So to answer question, no i have not and not sure what I can suggest to help but hope you get it figured out.
I'm having the same problem with headset volume limited through the bike vs phone. With some wind noise, I have to turn it all the way up. My last trip I gave up on the hand controls for actually being able to hear the music.

As for AKKPan's issue. I wonder if the headset is swapping between the phone and the bike. One suggestion is un-paid the headset from the phone.
 

·
Registered
'22 PAS Vivid Black
Joined
·
20 Posts
are y'all turning up the volume on your phones once connected and playing music?(this is different than the volume up and down on the bike controls). I have found on Android and iOS that the volume defaults to around half each time it connects to the bike and needs to be increased. It's super loud for me, I cant hear wind noise at 80mph when listening to music from phone through bike to my cardo packtalk bold.
 

·
Registered
PAS RA1250S Deadwood Green Spokes & ARH
Joined
·
196 Posts
Have a Sena 5S and the connection is pretty reliable. My Android phone connects right up to my bike faultlessly, they got that bit right. Best to pair the phone first and the headset second, IIRC? Don't be afraid to delete and try again until it works reliably. If you haven't had the software updates available, anything is possible. :oops:
 
1 - 8 of 8 Posts
Top