Harley Davidson Pan America Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Just bought my PA 2 weeks ago and put 1100 miles on it already! I traded my 2019 Road Glide in for it and even got a check back! Love the PA. It’s so much fun. The Bluetooth system sucks big time and that’s a bummer but hopefully HD will do an appropriate update.
anyway, I live near Fort Hood Tx and am always DTR if anyone wants to.
 

Attachments

·
Registered
Joined
·
49 Posts
Just bought my PA 2 weeks ago and put 1100 miles on it already! I traded my 2019 Road Glide in for it and even got a check back! Love the PA. It’s so much fun. The Bluetooth system sucks big time and that’s a bummer but hopefully HD will do an appropriate update.
anyway, I live near Fort Hood Tx and am always DTR if anyone wants to.
Welcome from Wyoming.
Funny thing, as I traded off my '17 Glide for the PAS as well. That bike beat me up too bad. Kept my Ultra Ltd though. will never get rid of that one.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
Wheel Tire Sky Vehicle Land vehicle
Welcome from Wyoming.
Funny thing, as I traded off my '17 Glide for the PAS as well. That bike beat me up too bad. Kept my Ultra Ltd though. will never get rid of that one.
I agree, the Glide beat me up much more than I expected it to. Right now I have my 97’ Dyna but I’m going to sell it too. It’s a great bike but I just need some cash right now. Just have to find someone willing to give me a fair offer.
 

·
Registered
Joined
·
34 Posts
Just bought my PA 2 weeks ago and put 1100 miles on it already! I traded my 2019 Road Glide in for it and even got a check back! Love the PA. It’s so much fun. The Bluetooth system sucks big time and that’s a bummer but hopefully HD will do an appropriate update.
anyway, I live near Fort Hood Tx and am always DTR if anyone wants to.
Is your Bluetooth sucking due to its always disconnecting?
 

·
Registered
Joined
·
34 Posts
My screen did that a few times then the VIN ERROR code came on and i did not have the odometer any more. It ended up being the IMU.
A for bluetooth mine kept randomly disconnecting. I had the Iphone 7. It worked great for the first few weeks then burp. My phone 3 months later finally died. I got an IPhone 11 and have not had any issues as of yet.
 

·
Premium Member
Joined
·
80 Posts
I have never had either of those issues. I had an oil pressure switch go bad, and the front speed sensor wire got pinched between the steering stop on the left side causing a break in the wire. That group of cables was poorly secured.
 
1 - 13 of 13 Posts
Top