Harley Davidson Pan America Forum banner
1 - 9 of 9 Posts

·
Registered
2021 Deadwood (OD) Green PanAm, 2007 Pearl Yellow RK Custom
Joined
·
67 Posts
Discussion Starter · #1 · (Edited)
A little perspective, I've got ~1800 stress-free great riding miles in less than two months. I've read others are having some issues with their bike and I Thank God my issue is clock doesn't know what time it is.

Anyways, I was hesitant to get PA since first run/gen but talking with buddy he said, "why not get one, hell look at me with my issues on BMW and they've been making them for damn near 40 years!" So I decided to get a PA for handful of reasons and buddy has Beemer so we can Adv ride and not be pigeon toed to asphalt/pavement.

He had bike a year or so and then his bike would (shut down) and only give him 5%throttle or ~2-3 mph!!! Yes it happens whenever/wherever it decided to fault out, one time he told me it happened on bypass going to work cruising at 65!

Also, where he bought it (1hr away) they quit selling bikes to focus on cars and there's not a lot dealers around here. He actually took it to three different dealers (all in different states) before one opened in Indy again and finally got the issue corrected. Not sure on timeframe but it wasn't within 6 months it was longer. Needless to say and I'll say he was very frustrated to keep this rated PG.

Just thought I'd put this out there so people aren't thinking HD and PA are having extraordinary problems. It happens even for BMW, so hopefully nothing major happens to you and the minors get iron out so we all can enjoy our new bikes!

I by no means trashing BMW, never owned one, buddy loves his and would consider buying one if HD didn't make PA, we actually have had three awesome rides together and hopefully many more in future with me on my PA!! Just saying grimlins get into everything.
 

·
Registered
Joined
·
9 Posts
Well stated, I think my PA falls into the "done is better than perfect" category, deliver the bikes and the bugs will get worked out. I've had plenty of new cars that needed multiple software updates. The clock issue is interesting, I've always heard a broken clock is right, 2x per day, unfortunately mine is a digital random number generator, I'm confident H-D will figure it out soon.
 

·
Registered
2021 Deadwood (OD) Green PanAm, 2007 Pearl Yellow RK Custom
Joined
·
67 Posts
Discussion Starter · #4 ·
Well stated, I think my PA falls into the "done is better than perfect" category, deliver the bikes and the bugs will get worked out. I've had plenty of new cars that needed multiple software updates. The clock issue is interesting, I've always heard a broken clock is right, 2x per day, unfortunately mine is a digital random number generator, I'm confident H-D will figure it out soon.
If you vluetooth your phone to your bike, it corrects the time on the clock.
If you vluetooth your phone to your bike, it corrects the time on the clock.
Heard people say sync with HD app works but I dunno as I don't have HD app... However, bluetooth doesn't work for me, granted I got cheap smartphone but I do connect the bike, phone, helmet and I'm able to listen to sirius playing thru phone with my helmet and can utilize PA buttons. And the clock still has mind of its own, use to run fast now it's behind. So maybe I got the random number generator too:D
 

·
Registered
Joined
·
9 Posts
Correct, and when you connect your phone to the bike via Bluetooth using the H-D app, it drains the phone battery within 4 hours and stores a huge amount of data which is why I no longer use the app, and will use my Garmin for navigation once a decent mount becomes available and H-D sorts out the USB-C port charging issue. This should be an easy fix or software update.
 

·
Registered
2021 Deadwood (OD) Green PanAm, 2007 Pearl Yellow RK Custom
Joined
·
67 Posts
Discussion Starter · #6 ·
Navigation? I don't need no navigation! It's an Adventure bike but seriously that's good to know and will hold off using HD app.
 

·
Registered
Joined
·
3 Posts
Mine keeps going into limp/go home mode and the dealer can’t figure out why. Neither can HD headquarters. first 1200 miles were great. Now i keep getting random limp mode events happening while riding. Not cool.
 

·
Registered
Joined
·
16 Posts
When I got mine, the radiator cap was loose and it overheated, had a couple hundred miles on it.. it went into limp mode twice. After I cleared all codes it has not done it again, I've got about 7600 miles on it now.
 
1 - 9 of 9 Posts
Top