Harley Davidson Pan America Forum banner
1 - 7 of 7 Posts

· Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
So when I was installing my new muffler I noticed there was a couple chunks missing from the coating on the rear suspension spring. The next time I was at the dealer I asked them about it and one of the guys from service looked at it then went and looked at a few other Pan Americas that were at the dealership and noticed the issue on at least three other bikes as well. So he said it must be normal. I say bullshit. Looks like the damage would have to be done when it was built. The bigger missing chunk was right behind the exhaust collection / resonator box, and the smaller missing piece was pretty much on the opposite side. So when you have a chance take a look and let me know if you have similar damage to your rear spring. Here are the pictures from my bike.

Tire Automotive tire Automotive lighting Hood Motor vehicle

Hood Automotive tire Automotive lighting Automotive tail & brake light Automotive exterior


And one at the dealer

Tire Wheel Fuel tank Vehicle Automotive fuel system

Hood Automotive tire Automotive exterior Bumper Auto part


Was easier to see on this one since they upgraded the muffler to the Screaming Eagle one. Looks like maybe damage from a spring compressor??? I am worried that now it is going to rust and get worse.
 

· Registered
Joined
·
9 Posts
So when I was installing my new muffler I noticed there was a couple chunks missing from the coating on the rear suspension spring. The next time I was at the dealer I asked them about it and one of the guys from service looked at it then went and looked at a few other Pan Americas that were at the dealership and noticed the issue on at least three other bikes as well. So he said it must be normal. I say bullshit. Looks like the damage would have to be done when it was built. The bigger missing chunk was right behind the exhaust collection / resonator box, and the smaller missing piece was pretty much on the opposite side. So when you have a chance take a look and let me know if you have similar damage to your rear spring. Here are the pictures from my bike.

View attachment 2401
View attachment 2400

And one at the dealer

View attachment 2403
View attachment 2402

Was easier to see on this one since they upgraded the muffler to the Screaming Eagle one. Looks like maybe damage from a spring compressor??? I am worried that now it is going to rust and get worse.
So when I was installing my new muffler I noticed there was a couple chunks missing from the coating on the rear suspension spring. The next time I was at the dealer I asked them about it and one of the guys from service looked at it then went and looked at a few other Pan Americas that were at the dealership and noticed the issue on at least three other bikes as well. So he said it must be normal. I say bullshit. Looks like the damage would have to be done when it was built. The bigger missing chunk was right behind the exhaust collection / resonator box, and the smaller missing piece was pretty much on the opposite side. So when you have a chance take a look and let me know if you have similar damage to your rear spring. Here are the pictures from my bike.

View attachment 2401
View attachment 2400

And one at the dealer

View attachment 2403
View attachment 2402

Was easier to see on this one since they upgraded the muffler to the Screaming Eagle one. Looks like maybe damage from a spring compressor??? I am worried that now it is going to rust and get worse.
My 2022 has the same problem I seen it the day I picked it up brand new. I didn’t say anything because I knew they would tell me some shit like they told you,but I’m still pissed about it every time I see it.
 

· Registered
Joined
·
37 Posts
Discussion Starter · #4 ·
Coating chipped brand new the day I purchased it
Yea I was not happy when the service guy looked at the other bikes there and saw the same thing and said "I guess that's normal" WTF. Now I am worried about long term damage. Not sure if it will rust and start bubbling off more of the coating.
 

· Registered
Joined
·
37 Posts
Same thing here on my '22. Noticed it when I removed the resonator box. "Thoughts and prayers" from the dealership. With everything else.....🍋
Lemonade, anyone?
 

· Registered
Joined
·
9 Posts
I was thinking about touch up paint. But now that I know other Pan Am’s have the same problem I want to know what the dealer has to say if he gives me the same bs they gave you I’ll call the company.I thought it was from them test riding and sitting it up.
 
1 - 7 of 7 Posts
Top