Harley Davidson Pan America Forum banner
1 - 20 of 43 Posts

· Registered
Joined
·
78 Posts
Discussion Starter · #1 ·
Hello - I’ve seen Error Codes discussed quite a lot on the forum, am curious if anyone has experienced a red VIN Error displayed on the center of their dash screen?? I’m getting a bit worn out on yellow triangles, check engine lights, ride mode faults, error codes, and now this 😐
Thanks-
Trip computer Gauge Automotive design Font Display device
 

· Registered
Joined
·
44 Posts
Same here. My went 739 miles and the IM module pukes. They put a new one in. The bike will still function. It just does not record the miles and your distance meter wont work. Mine took 3 weeks to come in and 4 days to install it. They had the engineer on the phone when they installed it, according to them.
 

· Registered
Joined
·
78 Posts
Discussion Starter · #5 ·
Thanks Holger and Gcross - I noticed the bike starts and runs just fine, didn't even consider that the odometer isn't registering. When they replaced your units, was the original (last known) odometer reading retrieved from the system?

I guess I'll contact a dealer on it... much appreciated.
 

· Registered
Joined
·
78 Posts
Discussion Starter · #9 ·
No it dont according to what the dealer told me. I told them what miles i had on it cause i clocked my milage through an gps app. They then added that to my odometer and put that in.
No it dont according to what the dealer told me. I told them what miles i had on it cause i clocked my milage through an gps app. They then added that to my odometer and put that in.
Interesting - I'll find out I suppose, made an appointment with my closest dealership today, and they can't get me in until October 11. Not happy about the super slow support from H-D dealers. And coincidentally I got the bike out earlier today and have a yellow triangle warning light, check engine light, AND the VIN error message on my screen. Very disappointing.
 

· Registered
Joined
·
44 Posts
Clear the codes but write it down first. Then see if they stay on. Mine did that while having the VIN issue. I snap shot it cleared them and started the bike and they were gone. Same codes would pop up time to time until they replaced the IMU.
 

· Registered
Joined
·
78 Posts
Discussion Starter · #11 ·
Thanks - I did look up and then clear the codes. Besides the bike having the yellow warning triangle on, the check engine light on, and the VIN Error lit up, I noticed it was NOT lowering when coming to a complete stop, despite the fact that the little yellow shock absorber light was flashing as if the suspension was lowered. I can tell because with my boots on I am pretty much flat footed when the bike lowers, and this was not the case. I ran it this morning and it's running fine with just the VIN Error code still lit up - I suppose it'll be that way until the dealer can get it in to look at it - a huge inconvenience.
 

· Registered
Joined
·
78 Posts
Discussion Starter · #12 ·
No it dont according to what the dealer told me. I told them what miles i had on it cause i clocked my milage through an gps app. They then added that to my odometer and put that in.
That seems odd, if not illegal by US regulations - if my VIN Error light is lit up (which it is) and I decided to sell the bike, it sounds like I would have to mark the title as "mileage unknown"?? As Holgi_SG pointed out, they thought the bike was clocking the odometer internally, but just not displaying the updated mileage on the screen until theirs was repaired. I suppose we'll find out after the dealer looks at it...
 

· Registered
Joined
·
44 Posts
Speaking of ARH. Mine worked sometimes for lowering. I found a link in this forum on checking out the connector for the ARH. Mine was wired wrong. I then fixed that and it is awesome. Im a Auto Tech for a major manufacturer, so i know my way around the electronic connectors.
 

· Registered
Joined
·
78 Posts
Discussion Starter · #15 ·
That much is true - I live in the Dallas, TX area and there are several dealers within 30 minutes from my house. Their knowledge of the bike (especially odd little intricacies) varies quite a lot from dealer to dealer.
 

· Registered
Joined
·
44 Posts
That much is true - ...f the bike (especially odd little intricacies) varies quite a lot from dealer to dealer.
I loved Texas when I visited.
I think Harley dropped the ball or the dealers did when this bike was coming out. When my employer comes out with a new or updated vehicle training goes out to the dealers. As a Tech if you don't pass the training you don't get to work on them. If your caught you and the dealer would get fined by the the manufacturer. I know that from a fellow tech breaking the rules. The tech got suspended from warranties for a month or so. The dealer I worked at got fined. Dealer had to pay back the monies that warranty paid on plus some. This all happened cause the manager was doing things he should of not have done and the tech got greedy.
I would love to say who I work for but am afraid of repercussion.
 

· Premium Member
2022 Harley Davidson Pan America Special
Joined
·
25 Posts
Curious, those with the VIN Error, are you using an aftermarket tuner with your bike, and if so, which one?

I have also had many different issues with my Pan America Special, that I took delivery of just about a month ago. I have 1300 miles on it and have had warnings for Traction Control, ABS, random TPMS lights with tire pressure at recommended PSI, super flaky bluetooth between phone/bike/headset. The latest being the VIN Error. The Traction Control and ABS turned out to be the wiring harness from the factory was not correctly seated in the ABS module, this was discovered after the second trip to the dealership for this issue. In all, my bike has been back to the dealership three times in the last month because of issues.

My bike has been at the dealership since Tuesday with no response as to what the problem is or when my bike will be fixed. I have been asked questions about what exhaust I have on my bike, which should have no bearing on the VIN Error issue, and asked if I have used an aftermarket tuner.
 

· Registered
PAN AMERICA 1250 Special
Joined
·
2 Posts
Hi everyone..
i am having the vin error too at the moment on my 2021 Pas. i had it checked by the technician here in Kuala Lumpur, Malaysia but they have no idea of what so ever of it. Advised to just ride it till they have the report replied (not sure who they sent the report to thou). Bike still is great working condition with no error popups. Only thing is i cant see the odo reading but can still scroll from range, temp, tripA and tripB. when left the scrolling at any of them, it will go back to the vin error after 2 secs..
Hope the report sent will be replied soon and share again here what's the outcome....
 

· Registered
PAN AMERICA 1250 Special
Joined
·
2 Posts
Clear the codes but write it down first. Then see if they stay on. Mine did that while having the VIN issue. I snap shot it cleared them and started the bike and they were gone. Same codes would pop up time to time until they replaced the IMU.
How do you actually clear the codes for VIN Error? its not the the diagnosis where all the error codes are shown.
Really appreciate if you can guide me to clear the VIN Error msg.
 
1 - 20 of 43 Posts
Top